Πανελλήνιες 2016: Οι λύσεις στην ανάπτυξη εφαρμογών

ανάπτυξη εφαρμογών 1

ΜΑΘΗΜΑ: ΑΝΆΠΤΥΞΗ ΕΓΑΡΜΟΓΏΝ ΣΕ ΠΡΟΓΡΑΜΜΑΤΙΣΤΙΚΟ ΠΕΡΙΒΑΛΛΟΝ

ΘΕΜΑ Α 

Α1.

  1. Σ
  1. Λ

3.Λ

4.Σ

5.Λ

 

Α2.

Α. Κατά την εισαγωγή του κόμβου με δεδομένα Ε ανάμεσα στον με δεδομένα Κ και δεδομένα Φ

Γίνεται έλεγχος  μνήμης με την τεχνική δυναμικής παραχώρησης για τον αν ο κόμβος με δεδομένα Ε μπορεί να εισαχθεί, οπότε  στην περίπτωση που ο κόμβος με δεδομένα Ε είναι προς εισαγωγή τότε ο δείκτης του κόμβου με δεδομένα Κ τοποθετείται στον δείκτη του Κόμβου Ε και ο δείκτης του κόμβου Κ θα λάβει τιμή την διεύθυνση μνήμης που καταχωρήθηκε  ο κόμβος με δεδομένα Ε

Β.  Κατά την διαγραφή του κόμβου με δεδομένα Κ ανάμεσα στον με δεδομένα Κ από την αρχή της λίστας τότε ο δείκτης του κόμβου Α θα λάβει την τιμή του δείκτη κόμβου με δεδομένα Κ

Α3.

Α. Καθολικές ονομάζονται οι μεταβλητές που μπορούν να χρησιμοποιηθούν σε όλα τα τμήματα του  προγράμματος άσχετα που έχουν δηλωθεί.

Β. Η χρήση των καθολικών μεταβλητών σε ένα πρόγραμμα όντως καταστρατηγεί μία από τις βασικές αρχές του τμηματικού προγραμματισμού αφού δημιουργεί προβλήματα και είναι αδύνατη για προγράμματα με πολλά υποπρογράμματα , αφού ο καθένας που μπορεί να γράφει κάποιο υποπρόγραμμα καλείται να γνωρίζει τα ονόματα όλων των μεταβλητών που χρησιμοποιούνται σε όλα τα υποπρογράμματα.

Α4.

Ο πίνακας Β[6] θα έχει την  παρακάτω μορφή:

15 7 12 8 8 1

1 2 3 4 5 6

 

 

Α5.

α. Στην περίπτωση κατά την οποία το Χ=22 θα εµφανιστούν οι τιµές:12 ,17, 22

β. Στην περίπτωση κατά την οποία το Χ=7 θα εµφανιστούν οι τιµές: 12,5,8

 

 

ΘΕΜΑ Β 

Β1.

  1. = 1
  1. = ΟΡΟΣ 3  = Σ
  1. = -1
  1. = 4

 

Β2.

1 2 3 4 5 6
1 1,2 2 2,3 2,3 2,3,4

 

 

ΘΕΜΑ Γ 

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ

! Γ1 ερώτηµα  

ΜΕΤΑΒΛΗΤΕΣ

 

ΑΚΕΡΑΙΕΣ: αρ_υπ, τεµ, Χ, χρέωση1, χρέωση2, Επιπλ_Κοστος ΑΡΧΗ

!Γ2 ερώτηµα 

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ‘∆ώσε αριθµό υπολογιστών προς πώληση’

∆ΙΑΒΑΣΕ αρ_υπ

ΜΕΧΡΙΣ_ΟΤΟΥ αρ_υπ > 0

!Γ3 ερώτηµα 

ΓΡΑΨΕ ‘∆ώσε τεµάχια παραγγελίας’

∆ΙΑΒΑΣΕ τεµ

ΟΣΟ αρ_υπ > 0 ΕΠΑΝΑΛΑΒΕ

ΑΝ αρ_υπ > τεµ ΤΟΤΕ    Χ   τεµ

ΑΛΛΙΩΣ     Χ     αρ_υπ   ΤΕΛΟΣ_ΑΝ

!Γ4 ερώτηµα 

ΑΝ Χ <= 50 ΤΟΤΕ    Χρέωση1     Χ*580

ΑΛΛΙΩΣ_ΑΝ Χ<= 100 ΤΟΤΕ

Χρέωση1      Χ*520

ΑΛΛΙΩΣ_ΑΝ Χ<=200 ΤΟΤΕ    Χρέωση1     Χ*470

ΑΛΛΙΩΣ

Χρέωση1       Χ*440

ΤΕΛΟΣ_ΑΝ

ΑΝ Χ <= 50 ΤΟΤΕ    χρέωση2     Χ*580

ΑΛΛΙΩΣ_ΑΝ Χ<= 100 ΤΟΤΕ

χρέωση2    50*580 +(Χ-50)*520

ΑΛΛΙΩΣ_ΑΝ Χ<=200 ΤΟΤΕ

Χρέωση2     50*580+50*520+(Χ-100)*470

ΑΛΛΙΩΣ

Χρέωση2     50*580+50*520+100*470+(Χ-200)*440   ΤΕΛΟΣ_ΑΝ

αρ_υπ     αρ_υπ – Χ

!Γ4Γ5 ερώτηµα

ΓΡΑΨΕ ‘Κόστος παραγγελίας’, χρέωση1

ΓΡΑΨΕ ‘Κόστος Κλιµακωτού υπολογισμού παραγγελίας ‘, χρέωση2

Επιπλ_Κοστος     χρέωση1 – χρέωση2

ΓΡΑΨΕ ‘Επιπλέον κόστος κλιµακωτής χρέωσης’, Επιπλ_Κοστος

ΓΡΑΨΕ ‘∆ώσε τεµάχια παραγγελίας’

∆ΙΑΒΑΣΕ τεµ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ _ΠΡΟΓΡΑΜΜΑΤΟΣ

 

 

ΘΕΜΑ ∆   

 

 

ΠΡΟΓΡΑΜΜΑ  Θέµα_∆

! ∆1 ερώτηµα  

ΜΕΤΑΒΛΗΤΕΣ

ΧΑΡΑΚΤΗΡΕΣ: ΚΩ∆[150000], ΦΥΛ[150000]

ΠΡΑΓΜΑΤΙΚΕΣ: ΧΡ[150000, 12], ΣΧ[150000]

ΑΚΕΡΑΙΕΣ: i, j, Θέση_Α, Θέση_Α

ΑΡΧΗ

! ∆2 ερώτηµα  

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 150000

ΓΡΑΨΕ ‘∆ώστε τον κωδικό του µαθητή’, i

∆ΙΑΒΑΣΕ ΚΩ∆[i]

ΓΡΑΨΕ ‘∆ώστε το φύλο του µαθητή (Α=Αγόρι, Κ=Κορίτσι)’

∆ΙΑΒΑΣΕ ΦΥΛ [i]

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12

ΓΡΑΨΕ ‘∆ώστε το χρόνο πρόσβασης για το µήνα’

∆ΙΑΒΑΣΕ ΧΡ[i, j]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 

 

 

 

 

 

 ! ∆3 ερώτηµα  

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 150000

ΣΧ[i]   0

ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12    ΣΧ[i]    ΣΧ[i]+ ΧΡ[i, j]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ∆4 ερώτηµα  

Θέση_Α ΘΕΣΗ_ΜΑΧ(ΦΥΛ, ΣΧ, ‘Α’)]

ΓΡΑΨΕ ‘ θέση Αγοριού, ΚΩ∆[Θεση_Α] Θέση_Κ ΘΕΣΗ_ΜΑΧ(ΦΥΛ, ΣΧ, ‘Κ’)

ΓΡΑΨΕ ‘ θέση Κοριτσιού’ ,ΚΩ∆[ Θεση_Κ]

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

 

! ∆5 ερώτηµα  

ΣΥΝΑΡΤΗΣΗ ΘΕΣΗ_ΜΑΧ (ΦΥΛ, ΣΧ, Χ): ΑΚΕΡΑΙΑ

ΜΕΤΑΒΛΗΤΕΣ

ΧΑΡΑΚΤΗΡΕΣ: ΦΥΛ [150000], Χ   ΠΡΑΓΜΑΤΙΚΕΣ: ΣΧ[150000], max

ΑΚΕΡΑΙΕΣ: i, max_θέση  ΑΡΧΗ  ! έξυπνη αρχικοποίηση   max     –1

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 150000    ΑΝ ΦΥΛ [i] = Χ ΤΟΤΕ

ΑΝ max > ΣΧ[i] ΤΟΤΕ      max      ΣΧ[i]      max_θέση     i

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΘΕΣΗ_ΜΑΧ max_θέση

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 

 

 

ΣΗΜΕΙΩΣΗ:

ΟΙ ΑΠΑΝΤΗΣΕΙΣ ΤΩΝ ΘΕΜΑΤΩΝ ΕΙΝΑΙ ΕΝΕΙΚΤΙΚΕΣ

 

 

 

 

Επιμέλεια απαντήσεων: Δαλεκτάκης Γεράσιμος